Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Theme Development Custom Post Type Templates in WordPress The Portfolio Homepage

Image Errors: Help!

I click on Portfolio, click on add new. Nothing shows up when I attempt to Insert Media. I can't search anything, and when I try to upload something I get:

"item-09.png An error occurred in the upload. Please try again later."

I then click on Media in the dashboard and I see that the file that had an error is actually in the Media Library.

Why would it register in the Media library but not be able to be pulled in or even foud when I try to 'Insert Media' when I 'Add New' in Portfolio?

This is my second time running through this course, and I had no problems the first time. Everything seems to be identical this time around in my code and process. Two things have changed:

1.) WP update from 4.5.2 to 4.5.3 2.) Windows 10 update

I should note that I switched themes and was able to successfully add images to the twentyfifteentheme. So it seems like it's an error with my theme or dashboard setup within this theme. I can't find the error. I've tried altering a few files with advice online with no luck thus far. Anyone have a similar experience or idea.

All the code in my main page files seems like it's fine...