Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Ruby Modules Ruby Core Modules Math

It doesn't work, no matter what I type

Hello,

I do't know how to fix this problem. I've tried everything and all I get is error message.

math.rb
@pi = nil
@e  = nil
@sqrt = nil
module Math
  puts Math::E = @e
  puts Math::PI = @pi
  @sqrt = Math.sqrt(9)
end

1 Answer

Steven Parker
Steven Parker
215,940 Points

Try doing it after "end", instead of doing it inside the module.   :wink:

Awesome! It worked. Thank you!