Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript AngularJS An Introduction to Two-Way Data Binding What is two-way data binding?

Launch Workspace button launching PIP from the Python course

Trying to launch the workspace for this video and it is launching the PIP workspace from the Python track. FYI

3 Answers

Dave McFarland
STAFF
Dave McFarland
Treehouse Teacher

Hi Brandon Meredith

Can you let us know how you launched the workspace -- from the green "workspaces" button or below in the "workspaces" tab. Or some other way?

My bad. It was the green "Workspaces" button during the video playback. I also refreshed the page a few times and got the same result as well as right clicking and selecting "Open link in new tab"

I'm wondering if we are having some caching issues here at my business. We are seeing some other strange anomalies here with Treehouse that you are not able to replicate.

Dave McFarland
Dave McFarland
Treehouse Teacher

Brandon Meredith

Are these anomalies all related to workspaces?

The more details you can give us the better,

thanks!

My co-worker is having some strangeness, which I have been able to replicate from my desk, where launching workspaces when the yellow banner stating that the video uses a new workspace is present will break the video in the background producing some strange black background. It goes away once you refresh, but seems to happen every time the yellow banner is present.

My co-worker has been emailing with a "Rob" who I am assuming is Rob Allessi and you guys are not able to replicate that on your end. Rob has screenshots and an email trail regarding that issue.

We are going to file a ticket with our local IT to see if maybe our caching servers can be flushed for Treehouse to see if that helps the strangeness we are seeing.

Dave McFarland
Dave McFarland
Treehouse Teacher

Thanks for the information Brandon Meredith.

I'll tag the workspaces folks to let them know about these problems. Let me know if you see anything else weird like this.

cc/ Matthew Spiel , Andrew Olson, Jim Hoskins

Will do. Thanks, Dave

Hey Dave,

With the breaking video issue. It puts some strange black/white icon into the background after crashing the video.

I did some basic troubleshooting with the Introducing Functions video in the Javascript Basics course.

My Win8 laptop with Chrome 40.0.2214.115m would do this every time if I deleted the workspace for that video so I was presented the banners stating that the video uses a new workspace prior to launching.

Rebooted my laptop into the Arch Linux install which had Chromium 40.0.2214.111(64) and the issue did not arise. I then updated the Chromium in my Arch install to .115 and the issue popped up again.

Hope this helps some.

Dave McFarland
Dave McFarland
Treehouse Teacher

Thanks Brandon. I'll bring this up with the workspaces team on Monday. Feel free to e-mail me at dave@teamtreehouse.com if other issues arise.