Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML HTML Basics Going Further with HTML Adding Developer Notes with HTML Comments

Arash Sammander
Arash Sammander
659 Points

MacBook Pro Finnish keyboard, comment shortcut <cmd>/ (amongst other shortcuts) w/chrome doesn't work.

I'm having problems with this comment shortcut <cmd>/, as well as a number of other shortcuts described in the video in the workspace. I'm using a MacbookPro with Finnish keyboard and the Chrome browser.

I've enabled the keyboard viewer to make sure that I am pressing the right combination of keys but still it doesn't work.

Could anyone give me a suggestion on what I may be doing wrong?

Antti Lylander
Antti Lylander
9,686 Points

Shortcuts don't work the same on Finnish keyboard.

On windows ctrl + ' (the key in between รค and enter) works for commenting. For indenting I use tab key.

Hope this helps.

3 Answers

Guil Hernandez Even though I disabled the option for the help menu the shortcut cmd+shift+7(/) does not work the workspace only takes cmd+/ but I don't have that key on my keyboard. I only know that key from a full keyboard but macbooks don't have that.

I would love the option to change shortcuts in the workspace or at least cmd+shift+/ to be recognized. That would make commenting a lot easier, which is an absolutely important thing students should learn to do!

Luca Martini
Luca Martini
Front End Web Development Techdegree Student 10,293 Points

mersadajan Same here. I have an Italian keyboard, I disabled the Help Menu shortcut on the Keyboard settings but it still doesn't work. Only when I change the keyboard in to English input Sources the <!----> shortcut works.

The "/" key, I find it on the "-" Key. So in my Italian Keyboard is: "CMD"+"-"

Nicole Schulte
Nicole Schulte
8,082 Points

My answer is late, but on my Mac it worked with pressing Shift as well. Cmd+Shift+/

Using Cmd +Shift + / doesn't work on mac if you have the option for the help menu enabled. It was on by default, so I had to disable it in the shortcuts menu in the keyboard settings.