Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Jenny Swift
Jenny Swift
21,999 Points

No internet on Android Studio Emulator

Hello. If I go to Settings > Wi-Fi, the switch is "on," and it says "AndroidWifi connected, no Internet." If I try to "Add network", give it a name, and click "save," nothing happens (and I'm not sure what values I'm supposed to choose before hitting "save"). And if I try to use the internet, it doesn't work. My computer is connected to the internet. I am new to Android. Please help.

1 Answer

Hi Jenny,

You probably have tried this but in the emulators cellular settings theres a drop down for "data status". Through this drop down you have the ability to emulate network conditions, make sure that it is set to home. The other options are roaming, searching, denied so this could cause a emulated error when your internet is actually connected.


Jenny Swift
Jenny Swift
21,999 Points

Thanks, Michael. If I go to Settings > Network & Internet > Mobile network, there is a switch for "roaming", and one for "mobile data," but I don't see the "data status" dropdown or "home" option you are referring to. Not sure if I'm looking in the wrong place or if it's a difference in the versions we're using.

I tried creating a new virtual device. The internet should just work with the default settings for a new virtual device, right? But it doesn't.