Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Development Tools

"No such file or directory" when I run "./configure"

For reference: Development Tools -- Console Foundations -- Installing Software -- Building Software From Source

I'm installing PyCharm, and unlike the video's SQLite example, the configure file must be in nested folders within. I ran a find command but to no avail. Advice, please?

bash: ./configure: No such file or directory
Dave StSomeWhere
Dave StSomeWhere
19,870 Points

Did you download the PyCharm source as opposed to downloading the trial (or purchased copy) from their site?

It should have an installation script. They should have installation instructions (something like extract the files, navigate to the bin directory and double click the install.sh)

1 Answer

Ah yes, you're right. I DLed the Community free version, and there's an Install Linux.txt file. Thanks Dave!