Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Build a Simple Ruby on Rails Application Getting Started with Rails Generate a Rails Application

Jeff B
Jeff B
401 Points

Object doesn't support this property or method

When I go to statuses I'm greeted with this message, I've tried changing the coffee script source to v-1.9.0 like some sites have said still no luck. I've even tried removing the file still no luck.

Object doesn't support this property or method (in C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/turbolinks-2.5.3/lib/assets/javascripts/turbolinks.js.coffee

Kevin Elliott
Kevin Elliott
15,653 Points

Can you post your Gemfile.lock and your full stack trace for the error?

1 Answer

Colin Bell
Colin Bell
29,679 Points

Not sure if it'll work, but give this a shot

Coffeescript 1.9.0 doesn't play well with Windows. On my Windows 7 machine, using version 1.8.0 solved this problem.

Add to Gemfile

gem 'coffee-script-source', '1.8.0'

then, run

bundle update coffee-script-source

and restart the server (if needed)