Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Theme Development Custom Post Type Templates in WordPress The Portfolio Homepage

Umy Ikem
Umy Ikem
21,383 Points

Portfolio Page not showing featured image using WP_Query

Hi i've followed Zac in the video word for word but can't get the Portfolio page to show the featured image. I also downloaded the project files and used the treehouse portfolio as my theme but the featured image still doesn't show. Any help with this please?? Code in page-portfolio.php is below

<?php 
/*
  Template Name: Portfolio Page
*/

?>

<?php get_header(); ?>



    <section class="row">
          <div class="small-12 columns text-center">
            <div class="leader">
            <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>

              <h1><?php the_title(); ?></h1>
              <?php the_content(); ?>        

              <?php endwhile; endif; ?>

            </div>
          </div>
    </section>

<?php 

  $num_posts = ( is_front_page() ) ? 4 : -1;

  $args = array(
    'post_type' => 'portfolio',
    'posts_per_page' => $num_posts
  );
  $query = new WP_Query( $args );

?>


<section class="row no-max pad">

  <?php if( $query->have_posts() ) : while( $query->have_posts() ) : $query->the_post(); ?>

  <div class="small-6 medium-4 large-3 columns grid-item">
    <a href="<?php the_permalink(); ?>"><?php echo "i dey here" ?></a>
  </div>

  <?php endwhile; endif; wp_reset_postdata(); ?>

</section>




<?php get_footer(); ?>

i also have theme support for post-thumbnails in my functions.php file

1 Answer

Umy Ikem
Umy Ikem
21,383 Points

i have fixed this. my post type slug was named portfolio-main & not portfolio. Got a hint from an answer in the community. Thanks