Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML How to Make a Website Creating HTML Content Add Image Gallery Content

Daniel Gladding
Daniel Gladding
3,721 Points

The images are showing as broken links, what am I doing wrong?

I have uploaded the images into workspaces. What am I missing?

<ul> <li> <a href="img/numbers-01.jpg"> <img src="img/numbers-01.jpg" alt=""> <p>Experimentation with color and texture.</p> </a> </li> <li>

3 Answers

Steven Parker
Steven Parker
229,921 Points

Did you upload them to a subdirectory named img?

This code will be looking for them in that subdirectory. If you accidentally uploaded them to the main directory, that would explain the issue.

If you need more help with your workspace, please make a snapshot of your workspace and post the link to it here.

Daniel Gladding
Daniel Gladding
3,721 Points

Possibly?

https://w.trhou.se/zxdmgx7bpg

When you say "main directory" are you referring to the folder entitled "How to Make a Website?"

Because I don't see a subfolder marked "img."

I had this same problem. I named the folder with Img not img once i changed it to a lower case i it worked just fine. Hope this helps!