Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

General Discussion

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

Why can't I type special characters like | and [] within the workspace console?

I've tried switching languages and used different OSs but nothing seems to fix it. I'm using the latest version of Chrome.

7 Answers

I could not reproduce this issue in Chrome on Mac or Linux. Perhaps you need to reinstall Chrome.
Have you tried this in the Firefox console?

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

Firefox has the same issue. I have Yosemite 10.10.4 if that makes any difference.

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

I've tried both english(US) and swedish(swe), but it made no difference.

Michael Afanasiev
Michael Afanasiev
Courses Plus Student 15,596 Points

Hi Beatrice,

I have seen this issue before with Nordic keyboards, could you try using a virtual keyboard instead and see if the issue persists?

In the meantime, I suggest you also shoot an email to the treehouse support team at help@teamtreehouse.com

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

Using the virtual keyboard didn't help. And I contacted the support to begin with, but they told me to ask here instead.

Michael Afanasiev
Michael Afanasiev
Courses Plus Student 15,596 Points

Give me some time, I will try to find you a solution. I'm hoping to find a permanent solution for future students as well.

In the meantime could you share a picture of your keyboard layout settings and the keyboard itself?

Michael Afanasiev
PLUS
Michael Afanasiev
Courses Plus Student 15,596 Points

Hey,

Try the following:

For curly braces {}: Shift+Alt/Option+8/9

For square brackets []: Alt/Option+8/9

Let me know if this works.

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

This is my physical keyboard layout: https://support.apple.com/library/content/dam/edam/applecare/images/en_US/keyboards/danish_notebook.png

And the Swedish Pro settings: http://i64.tinypic.com/290x2sn.png

The key combination that you suggested for {} and [] does not work.

Michael Afanasiev
PLUS
Michael Afanasiev
Courses Plus Student 15,596 Points

Hello again :)

Since you mentioned you are using OSX, are you using an Apple keyboard or a 3rd party one? Try writing brackets and curly braces using the keys in the layout (not what you see physically on your keyboard).

By the way, does this happen ONLY in Treehouse? I see that you write here on the forums, but not sure if you wrote that or just copy/paste.

Beatrice Nilsson
Beatrice Nilsson
6,234 Points

Hi!

I've been using both the built in keyboard and a third party (logitech). Both produces the same issue. However, I just discovered that if I use a keyboard with english physical layout and switch to english as my input source, I can write the special characters.

As far as I know this only happens within the workspace console here on treehouse. The forums and files in the workspace works perfectly.

Michael Afanasiev
PLUS
Michael Afanasiev
Courses Plus Student 15,596 Points

Hello Beatrice,

Since it happens only with Treehouse workspaces I suggest you email support again, but this time give them a link to this forum thread. Unfortunately I cannot troubleshoot their workspaces.

I think the treehouse developers should look into this, I'm sure they have a Nordic keyboard lying around there somewhere :P