Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

JavaScript JavaScript Loops, Arrays and Objects Tracking Multiple Items with Arrays Build a Quiz Challenge, Part 1

Workspace won't launch. I've tried in both Chrome and Safari. A pop up says I'm not authorized?

Workspace won't launch. A pop up says "Not Authorized". I've tried in both chrome and safari!

The same thing happened to me last night. I found that the workspace was in Workspaces (there should be an icon at the left side of your web page), and I could open it from there. I also found that I could open it using the link under Workspaces under the video.

Hope one of those work for you.

1 Answer

Jay Padzensky
Jay Padzensky
4,731 Points

Sorry for the troubles. We've been doing some work on our infrastructure lately which has caused a handful of these "not authorized" errors to appear for students. Please try to refresh the browser window, as the outage shouldn't last longer than a few minutes. Otherwise, please try to close your browser tabs, quit your browser, and reboot.

You may also be able to successfully launch the WS from different areas (e.g. in the Workspace tab underneath the video player or from the aforementioned WS menu). If the WS is new and you haven't added any code to it, you can delete it from the Workspace menu and attempt to launch it again from the video. Your patience is greatly appreciated! If you continue to face the issue, please let us know! help@teamtreehouse.com