Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Maria Victoria Reyes
Maria Victoria Reyes
17,731 Points

Gem::RemoteFetcher::FetchError on gem install compass

Hello guys,

I cant install compass. Running: gem install compass and gem install sass on windows cmd line both produces: ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError) Errno::ECONNREFUSED: No connection could be made because the target machine actively refused it. -connect(2) (https://your-dns-needs-immediate-attention.network/quick/Marshal.4.8/compass-1.0.1.gemspec.rz)

this also shows when i do gem install sass except the last error note would be /sass-3.4.3.gemspec.rz)

Im on windows 7, and gem version is 2.4.1

thanks in advance!

1 Answer

Maria Victoria Reyes
Maria Victoria Reyes
17,731 Points

Saw bunch of instruction at stackoverflow, doubting my capability to comprehend technical stuffs, so It took me a while to figure things out.

I did the following instructions through the link you have given Kang, talks there were spot on and I followed the much simpler version. I really didn't want to do the fixes in the command line. Not very well versed in that department. lol. Instead I did this, not mine but as suggested by the folks there. I have Adapted this instructions for windows 7:

Control panel -> network and Internet -> Network and Sharing Center -> Change adapter settings -> Local Area Connection (Right Click this)-> Properties -> TCP/IPv4 properties -> Properties -> Advanced... -> DNS tab -> and tick the Append these DNS sufixes (in order):, click the ADD tab and manually write the home.local and click ok.

hope this will also help people who encountered this problem. Thanks Kang.