Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML

Add a class called "social-links" to each anchor tag.

Add a class called "social-links" to each anchor tag.

<a href="#">Follow me on Twitter!</a> <a href="#">Send me an Email!</a>

i have answered this question like this:

<a href="#" class="social-links">Follow me on Twitter!</a> <a href="#" class="social-links">Send me an Email!</a>

but it is saying Bummer: You need to set the 'class' attribute of the first <a> element to "social-links".

Steven Parker
Steven Parker
229,952 Points

Sometimes an error elsewhere in the code can trigger a misleading validation message. It would help to see the whole code, and a link to the course page would also be very helpful.

5 Answers

Steven Parker
Steven Parker
229,952 Points

That link is great, but I still need to see the whole code also.

The little snippet you show here seems fine, so I'm thinknig perhaps some other change was made Iperhaps unintentionally?) elsewhere in the code that is throwing off the validation.

where are they suppose to?

please write for me so that i can continue

Steven Parker
Steven Parker
229,952 Points

You had them before when you said "i have answered this question like this:"

<!doctype html> <html> <head> <title>List Example</title> <link rel="stylesheet" href="styles.css"> </head> <body>

<a href="#">Follow me on Twitter!</a>
<a href="#">Send me an Email!</a>

</body> </html>

Steven Parker
Steven Parker
229,952 Points

But in this code, the class settings are not there!