Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (2014) Creating the Screen Layout Getting to Know Our Tools

After I run the emulator, the window for it appears but it just stays black the whole time. What shall I do?

I have been waiting for a couple of hours just in case it is taking long for being the first time, but nothing happens; no android logo nor anything else.

4 Answers

Paul Marino
PLUS
Paul Marino
Courses Plus Student 12,751 Points

Hey Juan! I've had those similar issues. Are you using the newest release of Android Studio, with the updated AVD Manager? If not (or if you're using Eclipse), you should see an option when you're creating the device, to "Use Host GPU" in the Emulation Options (try enabling/disabling that checkbox). If you're using Android Studio Beta 0.8.12+, It seems they've removed the checkbox to select/deselect the host GPU, in which case, in your AVD Manager, under the "Actions" tab, you'll see a drop-down menu where you can select "Show on Disk"... if you edit the "config.ini" file in there, you'll see the settings: "hw.gps=yes" and "hw.gpu.enabled=yes". Maybe try setting those to "no" instead, and see if that works. I've had similar issues recently with the Android L x86 preview images. Hope that helps!

Mustafa Eid
Mustafa Eid
332 Points

I have same problem and i could not find Actions tab, to see a drop-down menu under the tab titled "Actions" . Could you help me for this please if you do not mind,thanks.

Paul Marino
Paul Marino
Courses Plus Student 12,751 Points

Mustafa, are you using Eclipse or latest version of Android studio?

Thank you very much for such a comprehensive answer, Paul. It worked with the "Use Host GPU" thing for me, thanks!

Mustafa Eid
Mustafa Eid
332 Points

Thank you Mr.Marino for quick respond, Actually I am using Android Studio Beta 0.8.9 and I don't knew how to edit the "config.ini" file

aneesh kumar
aneesh kumar
1,426 Points

Hey , I'm just as new to this as you re I think. I faced the same issue with the emulator with the settings prompted by the instructor. I created a new emulator with new settings. Used nexus one instead. Try it.