Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

CSS CSS to Sass Installing Sass and Setting up the Project The --watch Command

After sass --watch scss:css. Flashing cursor won't let me go any further.

After I follow all of the steps change the directory it seems to be fine. Until I type in the sass --watch scss:css and hit enter. All I am getting is >>> Sass watching for changes. Press Ctrl-C to stop. Below that a flashing cursor and unable to type anything more. Shows no error.

After fixing the file extension I got the line showing the file for style.css and the style.c ss.map are created but I still am not able to go any further. Just a flashing cursor just below the text.

1 Answer

Kevin Korte
Kevin Korte
28,148 Points

So the watch command hijacks your command prompt and you can't type into it anymore, because you basically have a command that is running in perpetuation.

The way around this is you can open another tab on the command prompt, or another window, and set up your sass watch, and than in the second tab or window, cd back into the correct directory, and use that second one to enter new commands as you need to.

That worked. Thank you so much for your response.

Kevin Korte
Kevin Korte
28,148 Points

Glad that worked for you. You're welcome