Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Android Initial Setup Problem

I am on the intro video to android app development. When I downloaded the 32 bit windows packet it came with two files. A MAC OSX file and android_dev_environment folder. Inside of the _dev folder is the intial setup batch that I have to run. When I run it the command prompt comes up. The command prompt runs and goes through automatically. As the prompt runs multiple lines of text shows up inside of the prompt saying "The system cannot find the path specified". At the bottom of lines is a line that says: "ERROR: SWT folder ' ' does not exist." Then is goes on to say: " Please set ANDROID_SWT to point the folder containing swt.jar for your platform." Also when i try to run eclipse it says that it is not compatible with my version of windows. I have download both the 32 and 64 bit versions an they both do and act the same way. Please help ASAP.

1 Answer

James Barnett
James Barnett
39,199 Points

Use this path: c:\Users\%username%\ when you do the initial setup.