Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Android Build a Simple Android App (retired 2014) Getting Started with Android Android Setup and the Crystal Ball Project

Android Setup and the Crystal Ball Project

I happened to not have the eclipse console at all on the bundles below where the problems, javadoc, declaration taps are located on the ADT. Anyone have this same issue ? I also don’t understand why or what I did wrong ?

I did everything as the video tutorial and everything seem to work fine but when it is time to launch the app on the emulator (that load and worked just fine) , when I click on the play button and select run as android application, there won't be an issue but nothing seems to pop up as in the video the play drop down shows 1 crystal ball, on mine it shows me no launch history like if crystal ball didn’t exists when I did all the same as the video instructions.

Arthur Longbottom
Arthur Longbottom
13,110 Points

Can you post the code where the javadoc initializes the program? Might help us a little better to see where the code went wrong.

Sure, Thanks a lot for the reply. Is this it ?

<RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" android:layout_width="match_parent" android:layout_height="match_parent" android:paddingBottom="@dimen/activity_vertical_margin" android:paddingLeft="@dimen/activity_horizontal_margin" android:paddingRight="@dimen/activity_horizontal_margin" android:paddingTop="@dimen/activity_vertical_margin" tools:context="com.example.crystalball.MainActivity$PlaceholderFragment" >

    android:text="The anwser is yes" />


1 Answer

Iskandar Fendi
Iskandar Fendi
5,700 Points

Dear Ana,

I am trying to understand your problem here. What I get here is basically you either don't have CrystalBall app options when you select Run As or your Android Virtual Device doesn't pop up.

For my first assumption, Try to Run it in Package Explorer by Right Clicking on your CrystalBall folder and try to do the Run As

My second assumption, Try to wait for a little bit, The AVD for Android does run fairly slow to show up.

If none of my assumptions are correct, I believe it has to be something wrong with the Bundle that you have installed. I encountered that problem before; it popped up an error message said that I don't have a proper version for Android. Long story short, I decided to install both Eclipse and Android SDK tools separately. I installed Eclipse from eclipse website and Android SDK tools from Android Developer website (I found it in "Install Android SDK for existing IDE") It solved the problem and AVD manager is also included in that package.

Please let me know, if I understand your problem correctly.