Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


glenn romaniuk
glenn romaniuk
32,240 Points

android studio - genymotion - camera not working

I tried to turn on the camera and set the memory like the lesson but I can't find the settings for them in genymotion. I see a camera setting at runtime in the emulator. I've turned that on and set the cameras to 'dummy webcam'. When i click the button to take a picture it displays the error 'there was a problem accessing your cameras external storage'. Any suggestions?

more info...

I have an app i'm delveloping in android studio that uses the devices camera When i try to access the camera from genymotion emulator or an actual device i get the error "There was a problem accessing your device's external storage" I've tried to change back the sdk version to 21 but still does not work. I'm using the follow instructions.

For android studio users:

right click the App directory choose the "module setting" option change the ADK Platform as what you need Click Apply The gradle will rebuild the project automatically.

if i change the flavors tab target sdk version when i click apply it reverts back to 23.

this is what my gradle looks like

android {
    compileSdkVersion 21
    buildToolsVersion '21.0.2'

    defaultConfig {
        applicationId "com.immiso.glennr.ribbit"
        minSdkVersion 14
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile files('libs/Parse-1.11.0.jar')
    //compile 'com.parse:parse-android:1.+'
    // You must install or update the Support Repository through the SDK manager to use this dependency.
    compile 'com.parse.bolts:bolts-android:1.+'
    // You must install or update the Support Repository through the SDK manager to use this dependency.
    compile 'com.android.support:support-v13:19.+'

I would like to get this working as its an assignment. What do i need to change to get this working?