Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools

Wayne Hite
PLUS
Wayne Hite
Courses Plus Student 5,800 Points

Angular local environment blocker.

Hello, can anyone assist with an Angular local development issue I'm experiencing? I have a project which I cloned via git. Then I ran the following in the project root directory: npm install

Here are my results: npm ERR! code E404 npm ERR! 404 Not Found - GET http://registry.npmjs.org/@easydevops%2fangular-auth-plugin - Not found npm ERR! 404 npm ERR! 404 '@easydevops/angular-auth-plugin@^1.0.2' is not in the npm registry. npm ERR! 404 You should bug the author to publish it (or use the name yourself!) npm ERR! 404 npm ERR! 404 Note that you can also install from a npm ERR! 404 tarball, folder, http url, or git url.

Any ideas on how to correct this error? Here are some commands I've tried in my project root directory: npm install angular-auth-plugin npm install @easydevops/angular-auth-plugin@^1.0.2 npm config set registry http://registry.npmjs.org

I can't find any helpful info via Google search for angular-auth-plugin.

I also received the following error when I run: npm start

An unhandled exception occurred: Cannot find module '@angular-devkit/build-angular/package.json' Require stack:

  • /Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/node_modules/@angular-devkit/architect/node/node-modules-architect-host.js

- /Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/node_modules/@angular-devkit/architect/node/index.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/models/architect-command.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/commands/serve-impl.js

  • /Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/node_modules/@angular-devkit/schematics/tools/export-ref.js

- /Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/node_modules/@angular-devkit/schematics/tools/index.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/utilities/json-schema.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/models/command-runner.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/lib/cli/index.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/lib/init.js

/Users/../.nvm/versions/node/v15.8.0/lib/node_modules/@angular/cli/bin/ng

Commands I've tried to resolve the npm start error: npm install --save-dev @angular-devkit/build-angular npm audit fix npm install @angular/cli

The second error seems to be generated because of the "angular-auth-plugin" error.

When I run "ng update" I receive the following errors:

npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: ng-webapp@1.0.0 npm ERR! Found: typescript@3.1.8 npm ERR! node_modules/typescript npm ERR! dev typescript@"~3.1.6" from the root project npm ERR! peer typescript@">= 2.7 <3.3" from ng-packagr@4.7.1 npm ERR! node_modules/ng-packagr npm ERR! dev ng-packagr@"^4.2.0" from the root project npm ERR! peer ng-packagr@"^2.2.0 || ^3.0.0 || ^4.0.0" from @angular-devkit/build-ng-packagr@0.13.10 npm ERR! node_modules/@angular-devkit/build-ng-packagr npm ERR! dev @angular-devkit/build-ng-packagr@"~0.13.0" from the root project npm ERR! 1 more (@angular/compiler-cli) npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer typescript@"~3.9.5" from tsickle@0.39.1 npm ERR! node_modules/tsickle npm ERR! dev tsickle@">=0.34.0" from the root project npm ERR! peer tsickle@">=0.34.0" from ng-packagr@4.7.1 npm ERR! node_modules/ng-packagr npm ERR! dev ng-packagr@"^4.2.0" from the root project npm ERR! 1 more (@angular-devkit/build-ng-packagr) npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

I'm using the following versions: node v15.8.0 npm 7.7.6 Angular CLI: 11.2.6

Any help would be greatly appreciated.