Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

Another Heroku push rejected post

I've seen quite a few on here, but none share my error, which is as follows:

   Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
   /usr/local/bin/ruby extconf.rb
   checking for sqlite3.h... no
   sqlite3.h is missing. Try 'port install sqlite3 +universal'
   or 'yum install sqlite-devel' and check your shared library search path (the
   location where your sqlite3 shared library is located).
   *** extconf.rb failed ***
   Could not create Makefile due to some reason, probably lack of
   necessary libraries and/or headers.  Check the mkmf.log file for more
   details.  You may need configuration options.
   Provided configuration options:
   --with-opt-dir
   --without-opt-dir
   --with-opt-include
   --without-opt-include=${opt-dir}/include
   --with-opt-lib
   --without-opt-lib=${opt-dir}/lib
   --with-make-prog
   --without-make-prog
   --srcdir=.
   --curdir
   --ruby=/usr/local/bin/ruby
   --with-sqlite3-dir
   --without-sqlite3-dir
   --with-sqlite3-include
   --without-sqlite3-include=${sqlite3-dir}/include
   --with-sqlite3-lib
   --without-sqlite3-lib=${sqlite3-dir}/lib
   --enable-local
   --disable-local
   Gem files will remain installed in /tmp/build_34t00rpykd2w6/vendor/bundle/ruby/1.9.1/gems/sqlite3-1.3.7 for inspection.
   Results logged to /tmp/build_34t00rpykd2w6/vendor/bundle/ruby/1.9.1/gems/sqlite3-1.3.7/ext/sqlite3/gem_make.out
   An error occurred while installing sqlite3 (1.3.7), and Bundler cannot continue.
   Make sure that `gem install sqlite3 -v '1.3.7'` succeeds before bundling.

 !
 !     Failed to install gems via Bundler.
 !
 !     Heroku push rejected, failed to compile Ruby/rails app

Now as to the end of the error that says "gem install sqlite3 -v '1.3.7" I did that, and no change resulted in it. The commands listed up top, " 'port install sqlite3 +universal' or 'yum install sqlite-devel'", neither of them even work (I guess since I'm windows?). The only thing I did was add a path to my command prompt so I could even run heroku from my project directory. Any ideas?

4 Answers

I tried this, among other stackoverflow answers, and Heroku just gives me "We're sorry, but something went wrong."

James Barnett
James Barnett
39,199 Points

Email the support team at Treehouse at help@teamtreehouse.com and give them all the details of what you've tried so far.

I fixed it!

I ran this in the command line: heroku run 'rake db:migrate' -a (then the app name on heroku)