Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Java Basics Getting Started with Java Receiving Input

Nichelle Segar
Nichelle Segar
9,857 Points

Anyone else's workspace not loading?

I tried it in Chrome and Microsoft Edge. I also cleared browser history and tried to launch it but I get nothing. It just keeps loading.

same here but when i use visual studio code my program is running, i am currently on RSVP app JavaScript. how do i fix it? because i cant keep on downloading zipfiles over and over. please help, thanks in advance.

same here, i can compile one line of code but when I continue on with the course the console freezes. I am on Chrome.

6 Answers

Nichelle Segar
Nichelle Segar
9,857 Points

I took a break and came back a few hours later. It appears to be working again. Thanks!

Alexander Besse
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Besse
Full Stack JavaScript Techdegree Graduate 35,115 Points

Hi, Nichelle Segar!

Sorry to hear this is happening for you! You mentioned that you cleared the browsing history, have you tried clearing the browsing cache?

If you don't know how, here is a resource to show you from Digitial Trends: https://www.digitaltrends.com/computing/how-to-clear-your-browser-cache/

Or else, maybe a moderator can help if that doesn't work! Let me know how that goes.

Jonathan Grieve
Jonathan Grieve
Treehouse Moderator 91,250 Points

I think Alexander's link is a helpful resource. I was clearing browser history from Chrome earlier today and the amount of settings and screens you can click is about the size of a Web Application in itself.

Best to do it regularly for all the browsers you have, then it'll all become second nature. :-)

In the meantime, if it keeps happening, I'm sure Treehouse support will have the answers (beyond, try again in a few minutes) as to the status of Workspaces. You can click "support" or email direct at help@teamtreehouse.com

Rob Allessi
Rob Allessi
8,599 Points

Let us know if you're still having trouble with this and fire us an email at help@teamtreehouse.com. Usually, when this occurs, there's simply a communication error happening that resolves itself fairly quickly. Other times, we've seen things like user error where broken or looped code has been supplied into the workspace which is causing the problem.

Derek Lam
Derek Lam
1,012 Points

Doesn't work from the very beginning. What's the problem?

treehouse:~/workspace$ javac Introductions
Picked up JAVA_TOOL_OPTIONS: -Xmx128m
Picked up _JAVA_OPTIONS: -Xmx128m
error: Class names, 'Introductions', are only accepted if annotation processing is explicitly req uested
1 error

Adam Dunlap
Adam Dunlap
Courses Plus Student 1,899 Points

For others who run into the issue where the Workspace doesn't load, try pressing Command+R or Ctrl+R twice rapidly. So refresh the page, but refresh it again immediately, as in just click both buttons twice very fast.

To be clear, do this on the Workspace window, not the Video window.

For whatever reason, that seems to do the trick - for me anyways. This may help you avoid constantly having to clear your cache/cookies.