Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Setup Your Local Development Environment

Ceil-Ian Maralit
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Ceil-Ian Maralit
Front End Web Development Techdegree Graduate 19,422 Points

Apache Server WONT TURN ON (MAMP)

Only mysql is turned on, I looked for help online but can't find any. Only the opposite, why is it like this on mine?

jamesjones21
jamesjones21
9,248 Points

Hi Ceil-lan, just wondering, what port is MAMP using for your apache server? This is found within preferences and click on the ports tab, apache usually runs on port 80

Is there anything else using port 80?

If using windows: run cmd as administrator and type in netstat -abno

this will list all processes and the port they are running on, look for port 80. That may be the issue.

If not here is an article on mamp:

https://appsolute.zendesk.com/hc/en-us/articles/215197286-My-Apache-Server-will-not-start-

1 Answer

John Nguyen
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
John Nguyen
Full Stack JavaScript Techdegree Graduate 30,464 Points

Ceil-Ian Maralit : I'm a bit late, so you may have found a solution already. However, here is an alternative answer just in case another person runs into this issue in the future.

I was running MAMP(not pro) on Windows 10(64-bit) and the apache server wouldn't start. I found this solution from stackOverflow.

  1. Mamp -> Preferences
  2. PHP -> Change Standard Version to 7.2.14 (Or a different option than it is now)
  3. Click OK.

Mamp should restart and the apache server should run normally now.

This worked perfectly. Thanks!