Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript npm Basics Installing Packages with npm Managing Dependencies in the package.json File

app not working, node: symbol lookup error...

my app not working, when i tried node app.js in the console, it says:

node: symbol lookup error: /home/treehouse/workspace/node_modules/bcrypt/lib/binding/na pi-v3/bcrypt_lib.node: undefined symbol: napi_add_finalizer

2 Answers

David Savard
David Savard
9,599 Points

I have the same issue. I've contacted the support team and been redirected to the forum and the comunity. Since, this question is still pending, what can I do now?

Thanks

David Savard
David Savard
9,599 Points

The answer was in the next lessons of this course. From my understanding the issue is related to the bcrypt 0.8.3 version being incompatible with the newer node version.

So, I ran trough the console the command line : npm update bcrypt *** npm update bcrypt --save could work if you want to keep it saved into the package.json file.

After that simple command the bcrypt is the updated patched 0.8.7 version. Everything worked peachy fine when I ran the node app.js command afterwards!!!