Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Ruby on Rails 5 Basics Adding a Model Attribute Updating Views

Robert Fernandez
Robert Fernandez
3,524 Points

Body sections not showing

I've added the necessary text on show.html.erb to show the Body but for some reason its not showing up. Below is my code.

<p id="notice"><%= notice %></p>

<p>
  <strong>Title:</strong>
  <%= @post.title %>
</p>
<p>
  <strong>Body:</strong>
  <%= @post.body %>
</p>

<%= link_to 'Edit', edit_post_path(@post) %> |
<%= link_to 'Back', posts_path %>

1 Answer

Jay McGavren
STAFF
Jay McGavren
Treehouse Teacher

The code you're showing is in app/views/posts/show.html.erb, right? Sometimes when an object attribute doesn't show up in a view, it's because the attribute is actually set to nil or an empty string. Try adding the below line to your .erb file:

<%= debug @post %>