Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Development Tools

Bower, Bootstrap, Rails 4

So, I'm taking another swing at building the RoR app, so it sinks in, and since I last tried BS-3.0.0 has been released.

Looking through various posts and the BS docs it states to use Bower, I've installed it with ease through Rails' gem command.

Though when I run the install command for BS, it creates a new sub-directory and installs the assets and more in that directory, rather than putting all assets in the assets folder.

Any ideas?

2 Answers

Your best bet is to download and put the bootstrap files directly into the assets folder instead of trying to also add bower to the mix.

It's no longer a problem, I just failed to properly setup the assets route in .bashrc/.zshrc

In case anyone else reads this, it's done like this;

    "directory": "path/to/folder",