Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

Jordan Anderson
Jordan Anderson
19,560 Points

Brew Installation help (Ruby)

Jason Seifer

I am trying to install home brew and the other tools related to Ruby.

When I run the: ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"

the error is : "Failed during: /usr/bin/sudo /usr/bin/xcode=select --install"

I have installed gcc osx and the command line developer tools from Apple Developers site.

If I try to run xcode-select --install : "Usage: xcode-select -print-path or: xcode-select -switch or: xcode-select -version Arguments: -print-path Prints the path of the current Xcode folder -switch Sets the path for the current Xcode folder -version Prints xcode-select version information"

There is no pop up to install anything. Just the above message.

If I go into Xcode preferences, then to down load tab, Components : there is no option to select to down load the command line tools (i downloaded them from developers site)

I have been stuck for almost a week,

Thank you for your time and help.

1 Answer

Michael Hulet
Michael Hulet
47,869 Points

Try reinstalling Xcode, then install the Command Line Tools with Xcode (it usually prompts me to on first startup). After that, try running the command to install Homebrew again

Jordan Anderson
Jordan Anderson
19,560 Points

Thank you for your response Michael.

How do you install the command line tools with in xcode? I down loaded and installed the command lines tools from the developer site but still no luck.

When I run the curl command I get the same failed mesage : Failed during: /usr/bin/sudo /usr/bin/xcode-select --install

I wasn't prompted with anything at first startup. If i run: xcode-select --install in the terminal, i still get the same message as before.

Thanks again