Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build an Interactive Story App (Retired) User Input Introducing ImageViews

Christiaan Quyn
Christiaan Quyn
14,706 Points

"Build Failed" :app:processDebugResources FAILED

Every time I run this app it makes me lose my mind, I have no what's going on.

Android Studio has updated since Ben did these vids, I have added my own images with the same names and resolutions as Ben's mockups (to create my own interactive story). Placed the icon images into their respective mipmap folders and did same with the drawable folders. It's been a week and this just refuses to run and ... I think I'm going insane lol

Here's what is says on my Gradle Console

:app:processDebugResources FAILED

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':app:processDebugResources'.

    com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Users\Christiaan\AppData\Local\Android\sdk\build-tools\23.0.3\aapt.exe'' finished with non-zero exit value 1

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

here's my build.gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "kpqventures.wordpress.com.kpqinteractivetourapp"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.2.1'
    compile 'com.android.support:design:23.2.1'
}

Would greatly Appreciate anyone who could help me out !

1 Answer

Christiaan Quyn
Christiaan Quyn
14,706 Points

Yey I solved it ! Posting it here was a last resort , I felt it had something to with my images after days of research and reading a ton of stackoverflow Q/A's.

Here's to anyone who encounters a similar error -

Android studio only accepts images within a certain file name frame

Invalid file name: must contain only [a-z0-9_.]

Although I had checked my images multiple times , Windows 10 doesn't show you the extension on its file explorer , which for 3 images had been .PNG

I re-factored and renamed these images on android studio(right click - refactor - rename) to .png , it worked ! Oh Boy am I relieved :D

Good work, well done! :smile: :+1: