Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

WordPress How to Install WordPress on Your Computer How to Install WordPress on Your Computer Installing WordPress with DesktopServer

cannot acces mysite

I have configured a site without error at: http://test1.dev/wp-admin/install.php but i cannot access it through my browser. I get error 404 - site not found. I am running windows home 10 with iis 7

3 Answers

I fixed it - The problem was when you run Apache and IIS on same computer they both use same port (80). This needs to be changed. I changed the port for IIS from 80 to 81 under IIS-manager->default website->Bindings / after this both servers could run simultaneously.

The other thing one does not manually need to copy/paste the file "xampplite" to "C:\xampplite" - simply click at "Install DSL v381.exe" and follow the screen (do remember to shut down IIS before installation) if that is running. And also rember to change the port IIS later in order to run both servers on the machine.

It is pitty that teamtreehouse does not tell it in there installation procedure!

I did that, now I do not get more 404 error but it says that is cant reach the site.

Abdul-rahim Adam
Abdul-rahim Adam
4,513 Points

Was having same issue. I had mamp as well as DS running on my mac. I change my port number on my mamp to 80 earlier, but after reading this i went back to mamp again and changed the port to 81 and there it was.

Angelo Maiuri
Angelo Maiuri
8,353 Points


Try accessing http://test1.dev/wp-login.php and let me know if you got to the WordPress login screen. If not, it means you have misconfigured something.

Hope it helps, Angelo

I have tried that and also with http://localhost and http://(my local ip adr.) nothing is working i still get: Not Found HTTP Error 404. The requested resource is not found.

Efren Parra
Efren Parra
14,457 Points

im in the same thing, 404 page error :(