Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML Build an Interactive Website Google Maps Integration Adding a Dynamic Map

cannot get through this last Task for google api

its on the build and interactive website course, Google maps integration badge, Adding a dynamic map objective, the last question (question no.7)

the task is : Set the "theMap" to a new google.maps namespaced "Map" object with the parameters of "mapElement" and "mapOptions"

everything seems to be ok but I keep getting the error that previous tasks are no longer passing, which doesnt make sense

index.html
<!DOCTYPE html>
<html>
<head>
    <title>Map</title>
    <style type="text/css">
    body, html {
        margin:0;
        padding:0;
    }
    body, html, #map {
        width:100%;
        height:100%;
    }
    </style>
</head>
<body>

  <div id="map"></div>
    <script type="text/javascript"
      src="https://maps.googleapis.com/maps/api/js?key=AIzaSyAn8fk75K8kCdW6pQ4B7yoBHJNrUbleieY&sensor=false"></script>

    <script type="text/javascript">
      var mapOptions = {
        center: new google.maps.LatLng(28.42, -81.58),
        zoom: 18,
        mapTypeId: google.maps.MapTypeId.SATELLITE                       
   };

    var mapElement = document.getElementById("map");

    var theMap = new google.maps.Map(mapElement, mapOptions);
    </script>
</body>
</html> 

5 Answers

thanx carmine, I guess Im out of luck then, maybe i'll try it with different browsers of pcs

Carmine Maraglio
Carmine Maraglio
29,762 Points

Not sure if that will work. I tried with a couple different browsers and on the iOS app, still no luck. For what its worth, the code you have, is correct. :)

Sometimes when I've made a sytax error, etc I will get a previous task not passing error.

thanx lonnie, but it turns out its a bug in the software, hopefully they'll fix it soon cause I want my badge :P

:) I propose a strike