Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (2014) Creating the Screen Layout Getting to Know Our Tools

Cannot launch AVD in emulator on Windows: ERROR: x86 emulation currently requires hardware acceleration!

emulator: ERROR: x86 emulation currently requires hardware acceleration! Please ensure Intel HAXM is properly installed and usable. CPU acceleration status: HAX kernel module is not installed!

I tried downloading it but all I can find are things I have to purchase.

6 Answers

Ken Alger
STAFF
Ken Alger
Treehouse Teacher

Elijah;

You should be able to disable the hardware acceleration in your emulator. Take a look at the official documentation for Using the Emulator.

Ken

Both these answers helped a bit. The problem I'm currently running into after some more research is that my laptop has an AMD processor and not an Intel processor. I allowed Virtual Technology to be enabled through the BIOS menu of my computer but I still can't install the intel driver which seems to be the only thing that will allow it to work. I'm running on windows and not linux too

Charles Joseph McQuain
Charles Joseph McQuain
6,234 Points

I had this same exact issue on my computer, running Windows 8.1.

While I chose to install the appropriate module in the Android SDK Manager, it still didn't solve my issue. Through some research, I found that you install the driver directly through Intel's website: https://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager

This solved my issue, so I hope it brings you some luck. I read that this was an issue where possible anti-virus software was blocking the installer from Android SDK Manager. I currently use Avast as my anti-virus software.

Russell Comer
Russell Comer
26,102 Points

In some of the research I've done it shows that there is only support for AMD processor's if you are running linux, and if you have an Intel processor like i do and its about 3 years old it will not work either so then create a new generic AVD that does not use hardware acceleration or buy a new mac like I plan to do and then be able to develop iOS apps as well.

yep just run into the same issue (i had not idea that running AMD would be a issue - luckily i have a separate laptop i can use ..)

Abdulaziz B
Abdulaziz B
2,235 Points

There is a quick fix for this, you can still use an AMD processor.

You just need to use ARM Virtual Drive

Think video shows you how: https://www.youtube.com/watch?v=OjD9t1bfYsY