Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (2014) Getting Started with Android Setting Up an Android Development Environment for Linux

Cannot launch emulator

Waiting for device. "D:\Users\msfuser\Desktop\Muzinda Hub Training\android-studio\sdk\tools\emulator.exe" -avd Android442 -netspeed full -netdelay none

PANIC: Could not open: Android442 I have tried since morning and could not get solve this despite all suggestions . Treehouse please help. Its now 12 hrs am still stuck

Jeremy Castanza
Jeremy Castanza
12,080 Points

I had the same problem with this... Not the same error. But the same problem. I was able to install the IDE without an issue, but when it came time to run the emulator there were a lot of issues.

I think they need to update the video - since the IDE GUI has changed and doesn't really follow the video anymore.

3 Answers

Hello,

I'm going to guess by now you've tried creating a new emulated device and haven't had that run either. One option is to try using Genymotion, which is another emulation program that works for a lot of people when they are having issues with the default emulator. Treehouse has a course with involving it here. Please let us know if this helps.

Jeremy Castanza
Jeremy Castanza
12,080 Points

Hi James, yes that's correct... Thanks for the tip on Genymotion. Is it safe to assume that this integrates with Android Studio?

Thanks, Jeremy

I haven't used it personally, but from what I saw on the videos it should integrate well enough. You might need to start the emulator manually, but once its running, Android Studio should see that its a running device and run things nicely on it.

Pranav Nandu
Pranav Nandu
1,293 Points

Hey guys, I had a similar problem and so I searched the net for a solution. What worked for me was decreasing the RAM to 700MB in the emulator( although my computer RAM is 3GB). Hope this helps.