Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

ms2030
ms2030
2,973 Points

Cannot open Android SDK Manager

I successfully installed Android and SDK manager from Treehouse and then I updated stuff. I got everything to work except that I cannot open the Android SDK manager either from Eclipse or from the C:\android_dev_environment\android-sdk-windows\tools\android.bat

8 Answers

Although treehouse has a way to install the Android SDK with eclipse, I have seen many people running into problems with it. For eclipse install check out http://developer.android.com/sdk/installing/installing-adt.html This is how i do it, and it always works for me.

Can you do this for me? Go into Control Panel-> System and Security -> System -> Advanced System Settings -> Environmental Variables and make sure the JAVA_HOME reflects the location of the JDK on your system. Check in your Program Files for the location of the JDK and make sure you have the full filepath.

ms2030
ms2030
2,973 Points

I manually set JAVA_HOME to C:\android_dev_environment\Java\jdk1.6.0_35\bin

after getting that error. It had no effect.

Being new to Windows 8.1, I don't know how to go into Program Files to find anything but the above path looks like it has Java in it.

If I go to: Control Panel\All Control Panel Items\Programs and Features, then I see all installed apps. I do not see Java in the list. But even so I don't see a way to see the path. (I know how to do this in Windows 7 but not 8.1)

Do you have JDK installed? Or just JRE?

You Java path should not be pointing directly to bin. Remove '\bin' from the path. And try again.

You should have a file system as such. Program Files\Java\jdkX.X.X.X and your JAVA_HOME = C:\Program Files\Java\jdkX.X.X.X for the version of JDK you have. Then you should have a 'path' variable already set. Click 'edit' and then <strong>At the end of that 'path'</strong> variable add ' ;C:\Program Files\Java\jdkX.X.X.X\bin '
And this should get it running. Ignore the single quotes when adding to the path.

ms2030
ms2030
2,973 Points

I removed '\bin' from JAVA_HOME and it made it so "android" command worked from command line and within Eclipse!

Thanks everyone!

no problem glad this works now!

Are there any other details you would be able to provide? Such as any errors appearing in the console? Have you tried downloading the Android SDK Manager from Google directly instead of Treehouse? It can be downloaded as part of the SDK here: https://developer.android.com/sdk/index.html

ms2030
ms2030
2,973 Points

When I try opening SDK from within Eclipse, it just flashes a command prompt screen very quickly. If I type "android" from the command prompt, it says that I don't have Java installed. I added the JAVA_HOME variable as requested but I get the same error.

ERROR: No suitable Java found. In order to properly use the Android Developer
Tools, you need a suitable version of Java JDK installed on your system.
We recommend that you install the JDK version of JavaSE, available here:
  http://www.oracle.com/technetwork/java/javase/downloads

If you already have Java installed, you can define the JAVA_HOME environment
variable in Control Panel / System / Avanced System Settings to point to the
JDK folder.

You can find the complete Android SDK requirements here:
  http://developer.android.com/sdk/requirements.html

I'm afraid to reinstall the wrong stuff because it all worked before I updated things. I guess not having the SDK manager just prevents me from installing any future updates.

The odd thing is Eclipse works. I haven't found anything else that doesn't work.

You need to install the ADT plugin for eclipse follow this guide

http://developer.android.com/sdk/installing/installing-adt.html

I think you should be good to go if you do this. Or have you already done this?

one more consideration is going back to Environmental Variables and select the 'path' variable then click 'edit' go all the way to the end of the path and add -> ;C:\Program Files\Java\jdk.X.X.X.X for your jdk version. This adds the jdk to your Global Path. Have you done this?

You also need to make sure you have the Java Runtime Environment Installed on your Machine. It's available at

http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

Ben Jakuben
STAFF
Ben Jakuben
Treehouse Teacher

Thanks Kyle Jablonski and others for the good discussion in this thread. This has been a problem lately, especially on Windows. Your best bet is to probably switch to the bundle provided on the Android developer's site. When we refresh the Crystal Ball project we will switch to that as well. Perhaps this older Forum post might help: https://teamtreehouse.com/forum/problems-installing-windows-32bit-android-sdk

Erin Kabbash
Erin Kabbash
5,210 Points

I was banging my head against my desk trying to figure this out and none of the above solutions helped at all. Checkout this link: http://techathlon.com/fix-android-sdk-manager-failing-open-android-development-tools-bundle/ it helped me a lot.. also if that change doesn't work and you are getting an access denied message anywhere, right click the SDK Manager.exe file and click "Run as Administrator". That fixed mine! Hope this helps.