Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

C# Introduction to Xamarin Cross-platform Development with Xamarin Debugging the Android App

James Hammond
James Hammond
1,297 Points

Cannot run Emulator through visual studio with basic project

Hello,

I am having an issue with building the project and running on android emulator.

The project doesn't even build (it's a brand new project, i havnt touched the code)

"There were deployment errors. Continue?" is the option i have.

So I havnt been able to see anything on the emulator at all. Just a black screen

Deploy failed.

Seth Kroger
Seth Kroger
56,403 Points

This is a brand new course and I haven't worked with Xamarin before, but Android emulators will usually boot up like a regular phone/tablet and display a splash screen then a lock screen. I take it that's not happening? Are there messages that describe the errors?

1 Answer

Javier Mera
Javier Mera
16,472 Points

It sounds that if it fails to deploy, you will never see the installed app on the emulator. I found this on stackoverflow, https://stackoverflow.com/questions/40694554/getting-there-were-deployment-errors-continue-error-in-visual-studio-2015-xa

I initially had an error after installing all xamarin dependencies in VS 2017 related to API 25 not being installed on my system, and that the project was targeting API 25. I simply downloaded the tools for 25 through the Android SDK manager, and it worked.