Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS Build a Photo Browser iPhone App Connecting to an API using OAuth Introducing API and OAuth 2.0

Akshat Ratanpal
Akshat Ratanpal
903 Points

Cannot see the pod installed

I created the Podfile and the code within the file was:

pod 'SimpleAuth/Instagram'

Then I go into my project directory and when I run the command 'pod', I don't see any dependencies being installed.

Also, when I run the command 'pod list', I see '0' pods having been installed.

Could anyone help me out on resolving this issue?

Akshats-MacBook-Pro:Photo Bombers akshatratanpal$ pod list

0 pods were found Akshats-MacBook-Pro:Photo Bombers akshatratanpal$ ls Photo Bombers Photo BombersTests Photo Bombers.xcodeproj Podfile Akshats-MacBook-Pro:Photo Bombers akshatratanpal$ pod Usage:

$ pod COMMAND

  CocoaPods, the Cocoa library package manager.

Commands:

+ init       Generate a Podfile for the current directory.
+ install    Install project dependencies to Podfile.lock versions
+ ipc        Inter-process communication
+ lib        Develop pods
+ list       List pods
+ outdated   Show outdated project dependencies
+ plugins    Show available CocoaPods plugins
+ repo       Manage spec-repositories
+ search     Searches for pods
+ setup      Setup the CocoaPods environment
+ spec       Manage pod specs
+ trunk      Interact with the CocoaPods API (e.g. publishing new specs)
+ try        Try a Pod!
+ update     Update outdated project dependencies and create new Podfile.lock

Options:

--silent     Show nothing
--version    Show the version of the tool
--verbose    Show more debugging information
--no-ansi    Show output without ANSI codes
--help       Show help banner of specified command

1 Answer

Michael Hulet
Michael Hulet
47,911 Points

I think the command you're looking for is pod install