Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Game Development How to Make a Video Game The Unity Editor and Scene Setup Place Assets in the Scene View

Cannot select green boxes.

I cannot select the green boxes, I've look at the other questions and answers but they do not work, the anti aliasing is disabled. The console prints "Screen position out of view frustum (screen pos 1024.000000, 0.000000, 137712.671875) (Camera rect 0 0 1024 1024) UnityEngine.Camera:Render() UnityStandardAssets.Water.Water:OnWillRenderObject() (at Assets/Standard Assets/Environment/Water/Water/Scripts/Water.cs:128) UnityEditor.DockArea:OnGUI()"

Whats the problem, anyone know?

8 Answers

Nick Pettit
Nick Pettit
Treehouse Teacher

Cristian Yanez: Good news, I was able to reproduce this bug and figure it out. I have to say, I was pretty shocked when I also was not able to select anything. It's not just you!

I did some digging, and this is an officially documented bug with reflective water in Unity and it has been fixed in the upcoming v5.4.x release. Here's Unity's bug report: https://issuetracker.unity3d.com/issues/objects-in-scene-view-become-impossible-to-select-if-scene-contains-reflective-water

To fix this for now (until Unity v5.4.x is released), go to the Hierarchy window and open the "Environment" prefab. Then, select the "WaterProDaytime" game object. It should look like this:


In the Inspector window, simply disable the game object completely by clicking the checkbox in the upper left corner of the window (next to the name "WaterProDaytime". I've circled the checkbox in red - it should be unchecked to disable the game object.


Once you've disabled the water, you should be able to select game objects in the scene view again.

I hope that helps! Sorry that this bug came up - sometimes these things happen with Unity.

That helped so much!!! Something kind of of weird, we have the same last name..... But thanks for the help!?

That is so weird! But it worked! thanks!

Nick Pettit
Nick Pettit
Treehouse Teacher

Hi Cristian Yanez,

Sorry you're having trouble! This error can mean a few things. Here are some potential fixes:

  1. Select the camera game object in the Hierarchy window and then, in the Inspector, make sure that the camera's near clip plane is not set to 0. A value of 0.3 is usually good.
  2. Try right-clicking the scene view tab and then closing the tab. Then, from the Window menu (at the top of the screen) open the Scene tab again. Alternatively, you can close the Scene tab and the go to the Layout menu (in the upper right of the screen) and choose the Default layout to reopen the Scene tab.

I hope that helps! If not, reply here and we can keep working to figure it out.

The near clip plane is set to 0.3, and I tried step two and it still will not allow me to click an object.

What else could be causing this unusual act?

Here is a video; I've tried every solution. Maybe you notice something that is wrong, I hope :(


I may be having a separate issue, but if I single click it selects what looks like the entire environment. If I double click I'm able to select individual pieces and proceed.

Nick Pettit
Nick Pettit
Treehouse Teacher

Hi Buck,

That's the expected behavior. When you select a game object in the scene view, it will first select the parent-most object; in this case, the "Environment". If you click in the same place again, it will select individual game objects. That's how selection works in Unity's scene view.

Nick Pettit Thanks. In your video you say to 'click' but in fact it is to double-click.