Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App Testing and Debugging Running an App on a Device

Laith Mohammad
Laith Mohammad
6,569 Points

Can't install app on Note 5 , Emulator Control disabled in Android Device Monitor

Hi,

I've installed the following drivers:

  • Google USB driver from the SDK manager
  • Samsung driver
  • latest version of Samsung Kies

When I connect my Galaxy Note 5, my PC gives me the option to connect as MTP and I allowed it, but the device doesn't show in Android Monitor, I tried restarting Android Studio, Restarting my PC and it didn't work. I've also followed the instructions of some Stack Overflow answers, but no luck.

After being tired of this, I tried to use the Emulator Controls in the Android Device Monitor, but all controls are greyed out including telephone calls, messages, and coordinates.

Please help with these two problems as it's really REALLY annoying.

Thanks, Laith

2 Answers

Ben Deitch
STAFF
Ben Deitch
Treehouse Teacher

Hi Laith! It sounds like you've done pretty much everything you should have to do to connect your phone to your PC. The only thing I can think of is to check that the 'Use USB for' option on the phone (accessed from the USB notification) is 'File Transfer'. Other than that, it could be the USB cable itself. I've found a couple that just don't seem to work - they'll charge the phone just fine, but they won't connect it to a PC. Hope that helps!

Laith Mohammad
Laith Mohammad
6,569 Points

Hi Ben!

I tried every possible option but with no luck.. however.. I figured out how to export the project as an APK file and transfer it to my phone... and also I've used Genymotion which solved the problem now..

Thanks for the awesome tutorial though!

ur Student, Laith

Durim Kryeziu
Durim Kryeziu
14,002 Points

Hi I think you have forget to enable usb debugging in your phone please check