Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Ruby Foundations Ruby Basics Installing Ruby

Can't install homebrew?

I get...

Failed during: /usr/bin/sudo /usr/bin/xcode-select --install

any ideas?

7 Answers

Nick Fuller
Nick Fuller
9,027 Points

Do you have Xcode installed?

Yeah got the latest installed : /

Nick Fuller
Nick Fuller
9,027 Points

Have you installed command line tools?

Try opening terminal and running

xcode-select --install

read more here http://stackoverflow.com/questions/9329243/xcode-4-4-and-later-install-command-line-tools/9329325#9329325

Once you have command line tools installed, try restarting your pc (may not be necessary but that's how I usually roll :P) and then try installing homebrew again.

Let us know how it goes!

Nope still the same error after that command and a reboot...any other suggestions?

The password is my mac password right?

Alex Rodriguez
Alex Rodriguez
2,144 Points

I'm having the same exact issue and it's killing me. :(

yeah, I've still not solved it either....hope someone knows :P

Thomas Coler
Thomas Coler
8,068 Points

Open up the Xcode Application and go to Preferences. Under Locations, select command line tools and select the newest version and it will prompt you to enter your password. Close Xcode and then go ahead with your HomeBrew install. This worked for me.