Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

Can't install Homebrew on Mac OS X 10.9.2

So, apparently, command line tools was combined into Xcode on Mavericks, which is why I think I'm having issues installing Homebrew.

Here's the steps to reproduce the error:

  1. Enter the following command into the terminal:

xcode-selet --install

  1. Paste code into terminal: ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"

  2. Receive the following in return: ==> This script will install: /usr/local/bin/brew /usr/local/Library/... /usr/local/share/man/man1/brew.1

Press RETURN to continue or any other key to abort

  1. I hit Return

  2. After hitting return, I receive this message:

==> /usr/bin/sudo /bin/chmod g+rwx /Library/Caches/Homebrew Password:

  1. I enter my Root Password, which was recommended here on the forums.

  2. I receive this message after entering root password;

Password: Sorry, try again.

  1. I then enter my normal password and receive this error:

Installing the Command Line Tools (expect a GUI popup): ==> /usr/bin/sudo /usr/bin/xcode-select --install Usage: xcode-select -print-path or: xcode-select -switch <xcode_folder_path> or: xcode-select -version Arguments: -print-path Prints the path of the current Xcode folder -switch <xcode_folder_path> Sets the path for the current Xcode folder -version Prints xcode-select version information Failed during: /usr/bin/sudo /usr/bin/xcode-select --install

I'm not sure what's going on here. Any help would be much appreciated.

5 Answers

Thomas Coler
Thomas Coler
8,068 Points

Open up the Xcode Application and go to Preferences. Under Locations, select command line tools and select the newest version and it will prompt you to enter your password. Close Xcode and then go ahead with your HomeBrew install. This worked for me.

That worked Thomas. Thanks so much!

Hi Chas,

You do need to enter the admin password to install. Are you sure you entered it correctly? I believe the install is failing because it accepted the 'normal' password, which does not allow for installation.

Cena,

Yeah, I changed my root password again, just to make sure I was using the right one, and it did not accept the new root password, either.

Chas,

Try this walkthrough - scroll down to 'Is Xcode Already Installed?' and go from there.

Jason Seifer
STAFF
Jason Seifer
Treehouse Guest Teacher

Hey Chas Wagner sorry for the trouble! Those are some weird errors. If you're still having trouble with everything, try check out the VM instructions in Installing a Ruby Development Environment and following along with the tutorials from there.