Development Tools Installing a Ruby Development Environment Installing a Ruby Development Environment Installing Ruby on Mac

Liam George
Liam George
12,004 Points

Can't install Rails on a Mac

I can't seem to install Rails on my mac. I keep getting this message in Terminal:

Liams-Air:~ liamgeorge706$ rails -v /Users/liamgeorge706/.rbenv/versions/2.2.2/lib/ruby/site_ruby/2.2.0/rubygems/dependency.rb:315:in to_specs': Could not find 'railties' (>= 0) among 27 total gem(s) (Gem::LoadError) Checked in 'GEM_PATH=/Users/liamgeorge706/.rvm/gems/ruby-2.2.1:/Users/liamgeorge706/.rvm/gems/ruby-2.2.1@global', executegem envfor more information from /Users/liamgeorge706/.rbenv/versions/2.2.2/lib/ruby/site_ruby/2.2.0/rubygems/dependency.rb:324:into_spec' from /Users/liamgeorge706/.rbenv/versions/2.2.2/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_gem.rb:64:in gem' from /Users/liamgeorge706/.rbenv/versions/2.2.2/bin/rails:22:in<main>' Liams-Air:~ liamgeorge706$

PLEASE HELP ME!

1 Answer

William Li
PRO
William Li
Pro Student 26,799 Points

Hi, Liam George , I'd suggest that you check out this new workshop Installing a Ruby on Rails Development Environment in OS X, it has the updated instruction on how to get the latest Rails up and running on OS X.