Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML Introduction to HTML and CSS Make It Beautiful With CSS Test: Styling by Element and Class

Challenge task 1 (of 3) will not check my work ~help!

Intro to HTML & CSS Challenge section: after answering the task and clicking "Check Work" there is no response. please help me proceed....

index.html
<!doctype html>
<html>
  <head>
    <link href="styles.css" rel="stylesheet">
  </head>
  <body>

    <p>My amazing website</p>

  </body>
</html>
styles.css

James Murphy
seal-mask
.a{fill-rule:evenodd;}techdegree
James Murphy
Full Stack JavaScript Techdegree Student 6,585 Points

Is it not loading the page itself? Or is it telling you your code is incorrect. You must add the class "main-pg" to the p element in order for this to work. Otherwise it may be a problem with your connection.

<!doctype html> <html> <head> <link href="styles.css" rel="stylesheet"> </head> <body>

<p class="main-pg">My amazing website</p>

</body> </html>

Hi James, It doesn't seem to be a connection issue (I have high speed) and am able to move on t=with the other videos. I added the class to the element. The problem is that the system will not process the answer: when I click check work, the system says "working" but doesn't process "Correct" or "Bummer" as it normally does. Not thing occurs. Can you suggest anything else? Thanks in advance

POST SCRIPT: ...now, having bypassed that task for the sake of time and viewed the subsequent video section, I've come to another quiz. The system is having the same problem. After selecting my answer (in this case either A, B, or C) answer and clicking choose answer button, The system will not process the answers given. Please help.

2 Answers

Max Senden
Max Senden
23,153 Points

Hi Robin,

Everything is working fine for me. Did you install some funky plugins on your browser lately? Are you working with screenreaders? A touch screen perhaps? Did you try working with a different browser than your main one?

Hi Max ~ It is now resolved ...... It was mainly the fact that I was using Safari w/a plugin issue. I swtiched to Firefox and all is well! :) Thanks a million