Ruby Build a Rails API Coding the API Rails API CSRF Verification

Leo Brown
Leo Brown
6,896 Points

Cloud9 challenge: allowed network but still cannot render console

Hi, I am having trouble with creating a new list ("list" in my app, not "todo_list") via command line. I am using Cloud9 IDE which I think is related to the problem. At first I was receiving an error message saying "cannot render console" from the network. After googling, I whitelisted the network in the development.rb file. Now, I receive a modified (more concise) error message that seems to contradict itself.

Started POST "/api/lists" for 123.456.78.999 at 2015-09-14 14:53:33 +0000 Cannot render console from 123.456.78.999! Allowed networks: 123.456.78.999, 127.0.0.0/127.123.123.123, ::1

I've changed the network numbers because I am not savvy about security. But the point (and to me, the mystery) is that it says I can't render the console from a network that is apparently allowed (i.e., 123.456.78.999 === 123.456.78.999).

I would appreciate any advice on what could be the problem. I had no trouble following along with the tutorial until this step; the commands I entered led to the same result as in the videos.

This is the most recent command I've entered:

curl -i -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"title":"The Title will go here"}' https://myapp-me.c9.io/api/lists

Entering that URL instead of "localhost" has worked for me thus far but it could also be related to the problem. Cloud9 can be tricky.