Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS Build a Photo Browser iPhone App Connecting to an API using OAuth Introducing API and OAuth 2.0

Francisco Navarro
Francisco Navarro
14,185 Points

Cocoapod error in SimpleAuth/Instagram

I'm trying to use dependencies for Photo Bombers app and I'm getting next error:

"[!] Unable to find a specification for SimpleAuth/Instagram. "

I've just followed steps in video.What Am I doing wrong? thanks for helping

My Podfile looks like this:

target "Photo Bombers" do

pod 'SimpleAuth/Instagram'

end

2 Answers

So heres a few things I notice/did.

  1. My pod file only has the line pod 'SimpleAuth/Instagram' , meaning I don't have the other line you have.

  2. When he types pod in the terminal window, and it starts installing things, that is cool, but for me that does not work. Typing just pod simply gives me a list of options/commands that are available for pods. What I had to do was type pod install and then it analyzed the pods and installed everything.

  3. That being said, the first time I tried typing pod install it got stuck at analyzing dependencies. What I had to do was go back to terminal and type the following lines.

$ pod repo remove master

$ pod setup

$ pod install

So after doing the first two lines, you can then retry the third line. Something about redoing the setup fixed it for me, and it worked perfectly after this.

Hope some of this info helped you out!

Francisco Navarro
Francisco Navarro
14,185 Points

Definitely the third step worked for me! Thanks for such a good help!

Justin Montgomery
Justin Montgomery
2,088 Points

When I type pod install in step 2, I get the error "No `Podfile' found in the project directory." What are the steps for cd (changing the directory)?

It looks like there are a couple problems with the most recent version of Ruby and Apple's Developer Tools.

I would recommend following the steps listed below:

Open your terminal and immediately run: $ rvm install ruby-2.0.0-p481 Once that's done run: $ sudo gem install cocoa pods Navigate to your project file and run: $ pod install.

I hope this helps.