Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS iOS Tools CocoaPods CocoaPods


I tried to type sudo gem install cocoapods / even gem install cocoapods, but I keep getting the same error:

WARNING: Improper use of the sudo command could lead to data loss or the deletion of important system files. Please double-check your typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.


1 Answer

Daniel Johnson
Daniel Johnson
104,132 Points

It's just letting you know that you could mess up your computer if you type the wrong command. When you use sudo the computer is going to execute whatever you type regardless of what it will actually do.

For example, you could potentially erase all the data on your computer by typing the wrong thing. Safeguards exist to try to prevent you from doing something like that though, but you don't get any warnings when you use sudo. The computer will assume you know what you're doing.

You should be ok with the command sudo gem install cocoapods, so you could just type your password. It's also possible to install CocoaPods without using sudo, so if you're worried about typing the wrong thing in just try installing it without sudo like this gem install cocoapods.