Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


code not working in work space but in IDLE on my laptop it working fine. No hint or answers were provided. frustrating!!

Ugh, I made this list and now it has some invalid pieces in it. Maybe you can help me clean it up.Use the .remove() method to remove the last item from the list, please.

Initially given

states = [ 'ACTIVE', ['red', 'green', 'blue'], 'CANCELLED', 'FINISHED', 5, ]

I wrote in work space

states = ['ACTIVE', ['red', 'green', 'blue'], 'CANCELLED', 'FINISHED', 5]

states.remove (5)

after running it always giving bumper but when I run it on my PC IDLE python it runs well and removed the last item from the list that is the final result of list is coming

ā€‹['ACTIVE', ['red', 'green', 'blue'], 'CANCELLED', 'FINISHED']

Treehouse team it is quite frustrating that every time i stuck some where i have to post request. why test answers were not provided?

2 Answers

Chris Freeman
Chris Freeman
Treehouse Moderator 68,423 Points

Your code is close to correct. Do not put a space between remove and the parens:

states.remove(5)  # <-- no space

Some interpreters ignore the space and run anyway, but having the space is not recommended syntax by PEP 8. It best to break the habit as early as possible.

Julian Garcia
Julian Garcia
18,380 Points


I tried this:

states = [
    ['red', 'green', 'blue'],

without problem, try copying and paste it.

Hope it helps.