Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

CSS bootstrap file not loading, navbar not working "Laying Out the Page" Lecture

I'm on "Laying out the Page" lecture on Front-End Development section of Starting Ruby on Rails Course. I have installed Ruby 1.9.3 version, and I unzipped bootstrap version 3 onto my file and moved the required files per the instructions from the last lectures and have a working app running on localhost:3000 (I'm on a windows 7 machine and using command prompt btw). However bootstrap.css and other associated css files do not seem to work or load.

I get the following errors when I run the app server and load the ../statuses directory on the browser.

rails s: ... Started GET "/assets/application.css?body=1" for 127.0.0.1 at 2013-10-10 19:03:4 8 -0700 Served asset /application.css - 304 Not Modified (0ms)

Started GET "/assets/bootstrap.css?body=1" for 127.0.0.1 at 2013-10-10 19:03:48 -0700 Served asset /bootstrap.css - 304 Not Modified (1ms)

I also get the 304 errors for the scaffolds and status css

I tried to fix this using a suggestion from stackoverflow where you insert the line gem='thin' in the gemfile and then run bundle command to create associated files.

Still, the css does not seem to work or be loaded when I tried to work with the page again.

Please help, thank you!