Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Python Using Databases in Python Gettin' CRUD-y With It Add An Entry

Sasuke Uchiha
PLUS
Sasuke Uchiha
Courses Plus Student 298 Points

Ctrl+D is not working as EOF

It's not related to any editor. I even tried this on CMD and Git Bash. When I am pressing Ctrl+D, it's simply showing '^D' instead of passing EOF. I found an alternative, I need to press Ctrl+Z and press enter. But I need to do it as Kenneth did in the video. Any suggestions?

Here's a screenshot of the same.

Based on your screenshot it looks like you’re not on a windows machine. I don’t know that this will work, but if you’re using a Mac, maybe try Cmd + D.

4 Answers

Hi Mel,

Any chance you could send a screen shot of your terminal/command prompt?

Hank Tao
Hank Tao
7,540 Points

Went around the problem as per https://github.com/micropython/micropython/issues/3356 ctrl+d appears as \x04. The custom function finishes when \x04 appears on its own in a new line.

I also has the same situation when using my cmd on windows and only CTRL+Z is worked for me. When I press CTRL-Z, it will shows ^Z . I need to press "enter" to let it works.