Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Game Development How to Make a Video Game The Unity Editor and Scene Setup Navigating the Scene View

Tayyabah Noor
Tayyabah Noor
145 Points

darker screen view

why my screen view is darker than yours? when i dragged the enviroment asset to the heigharchy my scene is much darker than yours

4 Answers

Hi guys,

After you are done with following the video with the quality setting to Low and High, I tried this method and it worked for me for the scene view: Once your scene view is darker, right below the scene view tab you'll see some small icons and buttons. One button with 2D and next to it an icon of a sun. Click to turn off the sun icon. The icon should turn grey if it's off. That should make your scene view look less darker.

If that didn't fix it completely then keep the sun icon turned ON (the icon should light up if it's on) and then go to the Hierarchy tab. Click on the 'Main Camera' once. You should see a lot of options in the Inspector tab. Find the drop menu that says 'Camera' with a small picture of a camera. Find the option and uncheck 'Allow HDR'. It should be located almost towards the bottom. That should make your scene view a lot less darker. I hope this helps.

Ryan Mouser
Ryan Mouser
3,201 Points

Hi, Tayyabah!

I have also had the same issue, however, my Scene editor view / environment was consistent with Nick's until we changed the Quality settings (deleted the middle quality settings as instructed and kept/amended the Low and High Quality settings). I have reproduced the issue about 3 times by going through all of the Unity set-up videos and the issue occurs at the exact point of selecting either the Low or High Quality once the other settings were deleted and the Low / High Quality settings changed. I worked with the settings to see if the issue would resolve. I believe this may be due to being on the latest version of Unity (Unity 2017.1.0) and the process Nick outlines in the older version causes the Scene view to darken significantly.

Hopefully someone has a workaround or resolution to this issue. It is difficult to work with the asset details barely visible. Fortunately, the Game view shows as normal.

I look forward to someone's words of wisdom. :) Ryan

Bahman Sabeti
Bahman Sabeti
11,845 Points

Hi guys

I had the same Issue and I figure out if you change the player setting for color space back to gamma the scene gets brighter so at least you can work along but I'm not sure if it cause issue latter. Bahman.

I had the same problem. baderalsayegh' suggestion to turn off the sun solved it.

The course authors would be well advised to update their course to the latest version of unity.