Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Maven Project Structure

Does the pom.xml file need to already exist? Maven seems to think so...

When running:

mvn archetype:generate -B -DgroupId=com.teamtreehouse.com -DartifactId=file-spy

I get the following:

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.079 s
[INFO] Finished at: 2017-03-19T14:13:47-04:00
[INFO] Final Memory: 7M/309M
[INFO] ------------------------------------------------------------------------
[ERROR] The goal you specified requires a project to execute but there is no POM in this directory (C:\Users\kylew\Docum
ents\Projects\Maven). Please verify you invoked Maven from the correct directory. -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectException

Do I need to already have a pom.xml to use Maven? I thought Maven created one for me?

4 Answers

Alexander Nikiforov
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Nikiforov
Java Web Development Techdegree Graduate 22,175 Points

I'm not sure but judging from the post below


You don't have maven-archetype-quickstart that is used to build your project

Try typing

mvn archetype:generate

It should list your the possible archetypes like

:( $ mvn archetype:generate
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO] >>> maven-archetype-plugin:3.0.0:generate (default-cli) @ standalone-pom >>>
[INFO] <<< maven-archetype-plugin:3.0.0:generate (default-cli) @ standalone-pom <<<
[INFO] --- maven-archetype-plugin:3.0.0:generate (default-cli) @ standalone-pom ---
[INFO] Generating project in Interactive mode
[INFO] No archetype defined. Using maven-archetype-quickstart (org.apache.maven.archetypes:maven-archetype-quickstart:1.0)
Choose archetype:
1: remote -> am.ik.archetype:maven-reactjs-blank-archetype (Blank Project for React.js)
2: remote -> am.ik.archetype:msgpack-rpc-jersey-blank-archetype (Blank Project for Spring Boot + Jersey)
3: remote -> am.ik.archetype:mvc-1.0-blank-archetype (MVC 1.0 Blank Project)
4: remote -> am.ik.archetype:spring-boot-blank-archetype (Blank Project for Spring Boot)
5: remote -> am.ik.archetype:spring-boot-docker-blank-archetype (Docker Blank Project for Spring Boot)
6: remote -> am.ik.archetype:spring-boot-gae-blank-archetype (GAE Blank Project for Spring Boot)
7: remote -> am.ik.archetype:spring-boot-jersey-blank-archetype (Blank Project for Spring Boot + Jersey)
8: remote -> at.chrl.archetypes:chrl-spring-sample (Archetype for Spring Vaadin Webapps)

The other option would be to provide archetype your self


mvn archetype:generate -DarchetypeGroupId=org.apache.maven.archetypes -DarchetypeArtifactId=maven-archetype-quickstart -DgroupId=com.teamtreehouse.com -DartifactId=file-spy -B

You can also remove -B option and the process will be interactive

Hope that can help...

Jaime Moncayo
Jaime Moncayo
1,015 Points

I had the same error and got it to work by doing :

mvn archetype:generate -B -DgroupId=teamtreehouse -DartifactId=file-spy

You can also run Maven in interactive mode when starting a project, this way you don't have to remember all the -D flags. Maven will ask you questions about your project and suggest defaults, (like the aforementioned maven-archetype-quickstart).

mvn archetype:generate -DinteractiveMode=true

If you're familiar with JavaScript, it's similar to npm init or yarn init.

John Clune
John Clune
Courses Plus Student 4,951 Points

I got the same error message. Turned out to be the way Windows PowerShell reads the input. If you want to use a name like com.etc you have to wrap it in quotes.

mvn archetype:generate -B "-DgroupId=com.teamtreehouse" -Dartifact=file-spy

That's why it works when you remove the com. like Jaime Moncayo suggests.