Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Android Build a Simple Android App (retired 2014) Getting Started with Android Initial Layout

Eclipse 22.6.2 AVD...

I am unable to create a new android virtual device. I have been at this for a few hours now.

So far I have reinstalled the program multiple times, making sure that I have the correct directory for the SDK.

I have tried installing different versions of the ADT and Eclipse as well.

I have tried re-installing the ADT 22.6.2 as a plug in. I can't seem to find anything on the Android website or on Stack overflow that can solve this problem.

Has anyone else had any similar problems?

Edit: Just tried re-installing again under a new directory and getting this error: Could not find SDK folder 'User/Documents/adt-bundle/sdk'. Not sure if I am missing any files, when I ran the install file this time, it had said the AVD installed.. Im stumped.

4 Answers

1) Update your tools from the SDK manager

2) ADT version 23.0.0 has released and it will show an error if you don't install the new version. For that use the eclipse's install new software to install a new ADT plugin.

3) I would suggest get started with Geny Motion. Its really simple to set up and has lesser lags as compared to the default emulator by android.

And yes its free! :)

Hope it helps.

Treehouse video tutorials on Geny Motion

Side note on the ADT plugin... Not sure if this has happened for anyone else, but when I tried to update ADT it wasn't recognizing the update. You can download and install manually but when I did that I was getting "Conflicting Dependency" errors. I just ended up downloading the ADT bundle again and set the path to the workspace we were using for the Crystal Ball app, working fine now.

Thanks for the help! Genymotion looks really good, however I am getting a 'file corrupt' error for all of the virtual emulators I try to download on OS X 10.9.3.

Any ideas?

Did you download the virtual box for Mac?

Yeah, downloaded VB for mac installed and tried rebooting, still no luck :(