WordPress Installing WordPress Locally Installing WordPress Locally Enable Email for WordPress on Your Computer

Fathima Fas-ha
Fathima Fas-ha
6,847 Points

Enable Email for WordPress on Your Computer

Hi there!

Following error occured when attempting to send test email: SMTP Error: Could not authenticate.

CLIENT -> SERVER: EHLO localhost CLIENT -> SERVER: STARTTLS CLIENT -> SERVER: EHLO localhost CLIENT -> SERVER: AUTH LOGIN CLIENT -> SERVER: ZmFzaGFmYWhteUBnbWFpbC5jb20= CLIENT -> SERVER: ZmFobXkyMDE5QGdhbGxl SMTP ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials w3sm120677579pge.8 - gsmtp SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT SMTP Error: Could not authenticate.

Dave StSomeWhere
Dave StSomeWhere
19,785 Points

Did you turn on "Less secure app access" on your gmail account?

I use a separate gmail account for this, to make sure any of my real gmail accounts don't get messed up.

2 Answers

Ryan Thacker
Ryan Thacker
4,201 Points

Change to STARTTLS

John Nguyen
John Nguyen
11,566 Points

What if you got STARTTLS on with port 587. but still get errors?

CLIENT -> SERVER: EHLO localhost
CLIENT -> SERVER: STARTTLS
SMTP Error: Could not connect to SMTP host.CLIENT -> SERVER: QUIT
SMTP ERROR: QUIT command failed: SMTP Error: Could not connect to SMTP host.
Ryan Thacker
Ryan Thacker
4,201 Points

Sounds like your smtp settings are incorrect, what email are you using?

John Nguyen
John Nguyen
11,566 Points

Hey Ryan,

I'm using Gmail. I thought I had the correct settings, but I might be missing something here.

Here is a screenshot.

John Nguyen
John Nguyen
11,566 Points

Late, but I figured it out. I needed to check the box for 'Allow Insecure SSL Certificates' in the additional settings.